Help and Technical Difficulties

Take Me Riding is designed to work on a wide array of web browsers and platforms. However, to ensure games, videos, and other elements work properly, we must set minimum browser requirements. These are:

  • Firefox 28 (or higher)
  • Chrome 33 (or higher)
  • Safari 6 (or higher)
  • Internet Explorer 10 (or higher)
  • iOS 6 (or higher)
  • Android 4x (or higher)

The majority of Take Me Riding is designed to work on your desktop computer, tablet, or smartphone. However, certain games, such as Saddle Stories, have been developed using Adobe Flash and will therefore not function on most tablets and smartphone. Those games should be enjoyed on a desktop computer that has the Adobe Flash plugin installed.


If you are having trouble and need help with something specific on the site, please use our contact form to describe the problem. We'll do our best to look into the issue and help you out. Our aim is to make Take Me Riding as enjoyable and accessible as possible. 

Thanks for stopping by!!

The Take Me Riding Development Team